aboutsummaryrefslogtreecommitdiff
path: root/src-tauri/Cargo.toml
diff options
context:
space:
mode:
authorGeckoEidechse <gecko.eidechse+git@pm.me>2023-07-20 00:47:27 +0200
committerGeckoEidechse <gecko.eidechse+git@pm.me>2023-07-20 00:47:27 +0200
commit5f3dcdedbb0281cd52ec372c647f9b2ce4f860b7 (patch)
tree72e3ca3bfa8a536967c6b905704287ce2a1e4b2c /src-tauri/Cargo.toml
parent6d0d813c9af9fb43e2732652c5ec14d914dcea42 (diff)
parent29837bfe678dad64f01d6f6be69d43d659f402ae (diff)
downloadFlightCore-5f3dcdedbb0281cd52ec372c647f9b2ce4f860b7.tar.gz
FlightCore-5f3dcdedbb0281cd52ec372c647f9b2ce4f860b7.zip
Merge branch 'main' into feat/install-packages
Diffstat (limited to 'src-tauri/Cargo.toml')
-rw-r--r--src-tauri/Cargo.toml8
1 files changed, 5 insertions, 3 deletions
diff --git a/src-tauri/Cargo.toml b/src-tauri/Cargo.toml
index 1ce47b8a..1c758eb3 100644
--- a/src-tauri/Cargo.toml
+++ b/src-tauri/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "app"
-version = "1.23.0"
+version = "1.24.0"
description = "A Tauri App"
authors = ["you"]
license = ""
@@ -23,7 +23,7 @@ tauri-build = { version = "1.4", features = [] }
[dependencies]
serde_json = "1.0"
serde = { version = "1.0", features = ["derive"] }
-tauri = { version = "1.4", features = ["api-all", "updater"] }
+tauri = { version = "1.4", features = ["api-all", "dialog", "updater"] }
tokio = { version = "1", features = ["full"] }
# Sentry (crash) logging
sentry = "0.30"
@@ -33,7 +33,7 @@ steamlocate = "1.2"
# Error messages
anyhow = "1.0"
# libthermite for Northstar/mod install handling
-libthermite = "0.7.0-alpha"
+libthermite = { version = ""0.7.0-alpha", features = ["proton"] }
# zip stuff
zip = "0.6.2"
# Regex
@@ -62,6 +62,8 @@ zip-extract = "0.1.2"
# open urls
open = "3.2.0"
semver = "1.0"
+# simplified filesystem access
+glob = "0.3.1"
dirs = "5"
[target.'cfg(windows)'.dependencies]