aboutsummaryrefslogtreecommitdiff
path: root/src-tauri/Cargo.toml
diff options
context:
space:
mode:
authorGeckoEidechse <gecko.eidechse+git@pm.me>2024-08-02 02:43:39 +0200
committerGeckoEidechse <gecko.eidechse+git@pm.me>2024-08-02 02:43:39 +0200
commit3362cd9b55021c1325fc573a90ee0be22497bdeb (patch)
tree0aa139cd452fcb8d9f6bc9c6baac21e852b09f52 /src-tauri/Cargo.toml
parente5a74818e79e78d0e065d9375f38fd17a3a591a9 (diff)
parentedbce33c4a8f142967df868fb99476400f4ddfb3 (diff)
downloadFlightCore-3362cd9b55021c1325fc573a90ee0be22497bdeb.tar.gz
FlightCore-3362cd9b55021c1325fc573a90ee0be22497bdeb.zip
Merge branch 'main' into chore/bump-upload-artifact-action
Diffstat (limited to 'src-tauri/Cargo.toml')
-rw-r--r--src-tauri/Cargo.toml30
1 files changed, 18 insertions, 12 deletions
diff --git a/src-tauri/Cargo.toml b/src-tauri/Cargo.toml
index 2277ede0..c9a559a7 100644
--- a/src-tauri/Cargo.toml
+++ b/src-tauri/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "flightcore"
-version = "2.18.1"
+version = "2.23.2"
description = "Mod-manager for Northstar"
authors = ["https://github.com/R2NorthstarTools/FlightCore/graphs/contributors"]
license = "MIT"
@@ -23,49 +23,55 @@ tauri-build = { version = "1.5", features = [] }
[dependencies]
serde_json = "1.0"
serde = { version = "1.0", features = ["derive"] }
-tauri = { version = "1.5", features = ["api-all", "dialog", "updater"] }
+tauri = { version = "1.6", features = ["api-all", "dialog", "updater"] }
tokio = { version = "1", features = ["full"] }
# Sentry (crash) logging
sentry = "0.32"
-sentry-log = "0.32"
+sentry-log = "0.34"
# Find steam games
-steamlocate = "1.2"
+steamlocate = "2.0.0-beta.2"
# Error messages
anyhow = "1.0"
# libthermite for Northstar/mod install handling
-libthermite = { version = "0.7.0", features = ["proton"] }
+libthermite = { version = "0.8.1", features = ["proton"] }
# zip stuff
zip = "0.6.2"
# Regex
regex = "1.10"
# Read out running application process names
-sysinfo = "0.29.11"
+sysinfo = "0.30.12"
# HTTP requests
reqwest = { version = "0.11", features = ["blocking"] }
# Persistent store for settings
-tauri-plugin-store = { git = "https://github.com/tauri-apps/plugins-workspace", rev = "5a6abd3203dc94c38f96d0c4bf7ecbef399f8c25" }
+tauri-plugin-store = { git = "https://github.com/tauri-apps/plugins-workspace", branch = "v1" }
# JSON5 parsing support (allows comments in JSON)
json5 = "0.4.1"
# Async recursion for recursive mod install
-async-recursion = "1.0.5"
+async-recursion = "1.1.1"
# For parsing timestamps
-chrono = "0.4.33"
+chrono = "0.4.38"
# TypeScript bindings
-ts-rs = "7.1"
+ts-rs = "8.1"
# const formatting
const_format = "0.2.32"
# Logging libraries
pretty_env_logger = "0.5.0"
log = "0.4"
# Extracting zip files easily
-zip-extract = "0.1.2"
+zip-extract = "0.1.3"
# open urls
-open = "5.0.1"
+open = "5.3.0"
semver = "1.0"
# simplified filesystem access
glob = "0.3.1"
dirs = "5"
+# Interacting with GitHub
+octocrab = "0.38.0"
+# Library for removing markdown links
+remove-markdown-links = "1.0.0"
+
+
[target.'cfg(windows)'.dependencies]
# Windows API stuff
winapi = "0.3.9"