aboutsummaryrefslogtreecommitdiff
path: root/lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt
diff options
context:
space:
mode:
authorAdam Harrison <adamdharrison@gmail.com>2022-11-26 16:20:59 -0500
committerAdam Harrison <adamdharrison@gmail.com>2022-11-29 18:39:46 -0500
commitfc0c4ed9a3103e0e6534311923668879fc8e0875 (patch)
tree6e7723c3f45d39f06c243d9c18a3c038da948793 /lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt
parent3836606e2b735ba7b2dc0f580231843660587fb4 (diff)
downloadlite-xl-plugin-manager-fc0c4ed9a3103e0e6534311923668879fc8e0875.tar.gz
lite-xl-plugin-manager-fc0c4ed9a3103e0e6534311923668879fc8e0875.zip
Removed openssl, and curl, and added mbedded tls.curl-removal
Almost fully removed curl, needs more testing. Fixed most issues, now trying to cross compile. Fix? Sigh.
Diffstat (limited to 'lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt')
-rw-r--r--lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt b/lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt
new file mode 100644
index 0000000..29cbeb8
--- /dev/null
+++ b/lib/mbedtls-2.27.0/programs/x509/CMakeLists.txt
@@ -0,0 +1,30 @@
+set(libs
+ ${mbedx509_target}
+)
+
+if(USE_PKCS11_HELPER_LIBRARY)
+ set(libs ${libs} pkcs11-helper)
+endif(USE_PKCS11_HELPER_LIBRARY)
+
+if(ENABLE_ZLIB_SUPPORT)
+ set(libs ${libs} ${ZLIB_LIBRARIES})
+endif(ENABLE_ZLIB_SUPPORT)
+
+set(executables
+ cert_app
+ cert_req
+ cert_write
+ crl_app
+ req_app
+)
+
+foreach(exe IN LISTS executables)
+ add_executable(${exe} ${exe}.c $<TARGET_OBJECTS:mbedtls_test>)
+ target_link_libraries(${exe} ${libs})
+endforeach()
+
+target_link_libraries(cert_app ${mbedtls_target})
+
+install(TARGETS ${executables}
+ DESTINATION "bin"
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)